Fable is packaged only for Debian unstable.

Installing Debian for Debian unstable

Add the following to your APT sources lists:

deb [allow-insecure=yes] http://ci-prod-controller.vm.liw.fi/debian unstable-ci main

Then run the following commands as root:

apt update apt install fable

Running Fable from git

To run Fable from git, you need to clone the git repository and need Python 3, and the Markdown parser installed, as well as document typesetting tools, from Debian 10 (buster) or later:

sh sudo apt update sudo apt install make git locales-all pandoc python3 \ python3-pandocfilters python3-commonmark-bkrs python3-yaml \ texlive-latex-base texlive-fonts-recommended \ graphviz librsvg2-bin git clone git://git.liw.fi/fable-poc cd fable-poc

Note that fable-poc contains sample versions of the files for the echo acceptance tests (echo.md, echo.yaml, echo.py, and echo-prelude.py) so that you don't need to type them in yourself.